https://antibiotiqueaugmentin.com/surdosage-augmentin-bebe/
× Welcome to the ToolsJX forum!


Email protected from spambots

  • andreamarucci
  • andreamarucci's Avatar Topic Author
  • Offline
  • New Member
  • New Member
More
10 years 2 months ago #2662

Quite strange behaviour of TableJX. When I access the page all the email addresses are shown but as soon as I search for something, every result show the message that the email address is protected from spambots so it's not shown. I've to exit the page and reenter it again to see the email address but they disappears again as I search for something.

Can you fix this?

Please Log in or Create an account to join the conversation.

  • andreamarucci
  • andreamarucci's Avatar Topic Author
  • Offline
  • New Member
  • New Member
More
10 years 2 months ago #2663

BTW the Content - Email Cloaking plugin is enabled. If I disable it the emails are shown but they're not clickable as I would.

In the 2.5 version of the component that was not happening...

Please Log in or Create an account to join the conversation.

  • andreamarucci
  • andreamarucci's Avatar Topic Author
  • Offline
  • New Member
  • New Member
More
10 years 2 months ago #2665

Can someone let me know something about that? I cannot use the component in such a situation...

Please Log in or Create an account to join the conversation.

More
10 years 2 months ago #2666

Hi,

1. Enable plugin Content - Email Cloaking.
2. In the administration of Table JX find setting "Execute Content Plugins" in the "Advanced" section and set to "No".
3. Check the "Link?" checkbox in for your email column,
4. select the same column as "Link column",
5. choose Custom ID option with parameter

mailto:@ID

This should do it.

Attachment not found

Please Log in or Create an account to join the conversation.

  • andreamarucci
  • andreamarucci's Avatar Topic Author
  • Offline
  • New Member
  • New Member
More
10 years 2 months ago #2670

unfortunately not. These are my settings



But the result is always the same...

If you want to test I can give you access to the backend of the site...

Last edit: 10 years 2 months ago by andreamarucci.

Please Log in or Create an account to join the conversation.

More
10 years 2 months ago #2673

Apparently the suggested approach does not work while using Tools JX component directly, but it works if you put your grid into an article.

So I suggest, that you put the grid into an article and create a menu link to this article instead of creating menu link to Tools JX component directly.

Please Log in or Create an account to join the conversation.

Moderators: tomaz
Time to create page: 0.160 seconds

Contact Us

Contact us on Discord

Contact us on Facebook