https://antibiotiqueaugmentin.com/surdosage-augmentin-bebe/
× Welcome to the ToolsJX forum!


Table JX not working in slider

  • xfighter
  • xfighter's Avatar Topic Author
  • Offline
  • New Member
  • New Member
More
10 years 1 month ago #2745

Hello,

I put the free version of table jx into an article. The article is slided by using the Module Klixo Articles Slider.

With the free version I connected to the joomla database and it worked. But I have to connect to a mssql database. At this point one question.

Can I use the free version of table jx to connect to a mssql database?

I thought I have to get the paid version of table jx. But this is component. The slider seems to a a problem to slide the table grid provided in the article. In case I show the single article with the grid, everything is fine. Using the slider, the table grid is outside the sliding article, listed below the slider module.

How do I get this to work?

Please Log in or Create an account to join the conversation.

More
10 years 1 month ago #2746

Hi,

currently there is no official free version of Table JX.

Regards,
Tomaz

Please Log in or Create an account to join the conversation.

  • xfighter
  • xfighter's Avatar Topic Author
  • Offline
  • New Member
  • New Member
More
10 years 1 month ago #2747

Oh, I made a mistake. I also tried another table viewer that offers a free version.

I bought Table JX a few days ago, of course. And I am using the paid version. In case you need an evidence for that, please let me know and I will send you a paypal screenshot about the deal.

But the problem is still present.

Undefined property: stdClass::$id in D:\xampp\htdocs\toprank\components\com_grid\GridBuilder.php on line 478

Notice: Undefined property: stdClass::$catid in D:\xampp\htdocs\toprank\components\com_grid\GridBuilder.php on line 479[/i]

Do you have any suggestions?

Last edit: 10 years 1 month ago by xfighter.

Please Log in or Create an account to join the conversation.

More
10 years 1 month ago #2748

Hi,

In which case does the problem appear? Do you have it somewhere online? Could you attach a screenshot of Tools JX configuration for the view where the errors appear?

Regards

Please Log in or Create an account to join the conversation.

  • xfighter
  • xfighter's Avatar Topic Author
  • Offline
  • New Member
  • New Member
More
10 years 1 month ago #2749

Hi tomaz,

I do not have it online. At the moment I use xampp.

In deatails. I installed table jx and it can be opened by using the menu 'components'.
The following settings were done: see attached 'pic1'

Attachment not found



Than I have an article where the table is selected to be visible:

For the slider, I use mod_bt_contentslider.

The result is visible in pic2. The table is shown below the slider and not inside the sliding article.

Attachment not found





When I disable JX table, it looks like in pic3. No error message that refers to the gridbuilder.php.


Attachment not found





After that, I tried 2 other conetn slider. One of them shows the same error message, the other one does not display a message and also not a table anywhere.

It seems to be a problem in the gridbuilder.php.

Last edit: 10 years 1 month ago by xfighter.

Please Log in or Create an account to join the conversation.

  • xfighter
  • xfighter's Avatar Topic Author
  • Offline
  • New Member
  • New Member
More
10 years 1 month ago #2750

I tried something but still receiving the error messages. A kind of table is shown, but not nice.

For testing I selected a joomla table.

How do I solve the problem?


Attachment not found

Last edit: 10 years 1 month ago by xfighter.

Please Log in or Create an account to join the conversation.

Moderators: tomaz
Time to create page: 0.171 seconds

Contact Us

Contact us on Discord

Contact us on Facebook