https://antibiotiqueaugmentin.com/surdosage-augmentin-bebe/
× Welcome to the ToolsJX forum!


TableJX issue with undefined variable after instal

  • markjw
  • markjw's Avatar Topic Author
  • Offline
  • New Member
  • New Member
More
8 years 6 months ago #2907

Hi Guys,

Looking forward to get the Tables up on running on my site.

Immediately after install I am receiving 3 of these errors on the backend after the following:

1. select Components - Tools JX
2. choose New

The following error boxes are shown, usually 3 times

Notice: Undefined variable: _DB in C:\wamp\www\pibb4\administrator\components\com_grid\models\grid.php on line 152

Looks like everything installed successfully:

Anything obvious I am missing. Seems like it is connected to the DB as I can see the tables. Joomla is 3.1.5 stable...pretty much stock without other packages installed.

Also tried install on a 3.2.3 site and same issues.

Cheers.

Last edit: 8 years 6 months ago by markjw.

Please Log in or Create an account to join the conversation.

  • markjw
  • markjw's Avatar Topic Author
  • Offline
  • New Member
  • New Member
More
8 years 6 months ago #2909

Hi guys,

I have added the third line of code below in models/grid.php

function &getTbList()	{
		$db;
		$_DB= null;    // initialize the object

This resolves all the error messages I was getting on the backend. Perhaps it was related to some PHP type checking parameter that was set too strictly.

Cheers.

Last edit: 8 years 6 months ago by markjw.
The following user(s) said Thank You: tomaz

Please Log in or Create an account to join the conversation.

  • markjw
  • markjw's Avatar Topic Author
  • Offline
  • New Member
  • New Member
More
8 years 6 months ago #2912

Continue talking to myself..

It you turns out, that is you turn off the PHP setting called "display errors" then you wont see any of these errors.

There are also quite a few of these that would show up if you are using the advanced search filters and are displaying errors.

Cheers.

Please Log in or Create an account to join the conversation.

More
8 years 5 months ago #2915

Hi,

You have been able to answer all your questions so well... =)

We have been trying to clear those those messages out, but apparently still some of them are there. It depends a little also on the PHP version you are using.

The quick solution is to set error reporting to lower level in Joomla global configuration.

Please Log in or Create an account to join the conversation.

Moderators: tomaz
Time to create page: 0.193 seconds

Contact Us

Contact us on Facebook